谷动谷力

 找回密码
 立即注册
查看: 2228|回复: 3
收起左侧

【ZigBee 系列】| NXP-JN5169 ZigBee 3.0 开发环境搭建及编译

[复制链接]
发表于 2022-11-25 23:22:45 | 显示全部楼层 |阅读模式
【ZigBee 系列】| NXP-JN5169 ZigBee 3.0 开发环境搭建及编译


一、概述
        初次接触 ZigBee,一头雾水,无从下手。今天就和大家一起从 NXP ZigBee 环境搭建开始一步步学习 ZigBee 相关的知识。
        首先必须在 NXP官网 注册一个的账号,需要填写一些基本信息,邮箱收到激活链接以后点击激活重新确认信息,完成注册。

         1.png


二、安装NXP JN516x IDE & SDK

2.1、下载开发工具:BeyondStudio for NXP-JN-SW-4141
         这是一个基于 Eclipse 的 IDE 开发环境,名称为 BeyondStudio for NXP。

2.2、安装 BeyondStudio for NXP

         2.png

        单击 I Agree,一路 Next,出现下面界面,可在此更改安装路径,然后 Install,最后等待安装完成,点击 Finish【建议默认路径安装】。

         3.png

2.3、下载 JN-SW-4170 SDK 安装包
        在官网里点进去,会有三个 SDK 选择下载,我们选择 JN-SW-4170 ZigBee 3.0 v1745。

         4.png

2.4、安装NXP-JN-SW4170 ZigBee 3.0 SDK
        该安装路径默认与 BeyondStudio for NXP 安装路径一致,若不一致,需自行更改为一致。

          5.png

2.5、安装 ZigBee 插件
  • 打开 BeyondStudio for NXP,选中 Help --  Install New Software

         6.png

  • 在 Available Software 界面,单击 ..

         7.png
  • 显示如下窗口,单击 ..

         8.png

  • 浏览到已安装 SDK 插件的文件夹,例如:C:\NXP\bstudio_nxp\sdk\JN-SW-4170\Tools\Eclipse_plugins\com.nxp.sdk.update_site

         9.png

  • Name里面输入 plug-in

         10.png

  • 将 NXP ZBPro SDK 展开,将 Jennic RTOS Configuretion Editor 和 Jennic ZBPro Configuration Editor 前面的复选框打上勾。

         11.png


  • 当屏幕出现 Review Licenses 时,选择 I accept the therms of the license agreement,然后 Finish 继续。

         12.png
  • 出现如下界面,等待进度条跑完

         13.png

  • 出现如下界面,单击 OK 继续

         14.png

  • 出现如下界面,单击 Yes,软件自动重新启动,安装完成。

         15.png

三、示例代码编译

3.1、下载 ZigBee 3.0 的代码
        NXP 官网提供了控制器和开关设备模板 JN-AN-1219

          16.png

3.2、打开工程
  • 右击 Project Explorer 空白处,选择 Import

         17.png

  • 选中 General -- Existing Projects into Workspace – Next 继续

         18.png

  • 选择 ..,选择工程文件夹路径

         19.png

  • 只勾选 JN516x 工程

         20.png

  • 单击 Finish 结束,完成工程打开。选中工程,点击右上角的小锤子符号编译工程。

         21.png

到这里,关于 ZigBee 开发环境的下载和安装已经全部完成,

关于 ZigBee 的开发环境安装包和相关文档,也可以参考附件资料:user guide~
+10

本帖被以下淘专辑推荐:

  • · zigbee|主题: 38, 订阅: 0
回复

使用道具 举报

发表于 2023-5-15 23:00:18 | 显示全部楼层
安装插件不成功 怎么办呢?

出错内容如下 :
the version of beyond studio  is : Build 1308
sdk jn 4170 is : Build Number 1745
I've reinstalled it twice in the default path and on D drive, and it still doesn't work.
when i install the plugin (ZB pro configuration edition 2.0.0), i have the message error :Cannot complete the install because one or more required items could not be found.
Software being installed: NXP ZBPro Configuration Editor 2.0.0 (com.jennic.sdk.zbpro.external.feature.feature.group 2.0.0)
Missing requirement: ZBPro Config Edit Support 2.0.0 (com.jennic.zps.configeditor.edit 2.0.0) requires 'bundle org.eclipse.emf.edit 0.0.0' but it could not be found
Cannot satisfy dependency:
From: NXP ZBPro Configuration Editor 2.0.0 (com.jennic.sdk.zbpro.external.feature.feature.group 2.0.0)
To: com.jennic.zps.configeditor.edit [2.0.0]

点评

安装插件不成功也没有关系, 不影响使用SDK  详情 回复 发表于 2023-7-11 13:50
+10
回复 支持 反对

使用道具 举报

发表于 2023-7-11 13:50:12 | 显示全部楼层
谷谷小师妹 发表于 2023-5-15 23:00
安装插件不成功 怎么办呢?

出错内容如下 :

安装插件不成功也没有关系, 不影响使用SDK
+10
回复 支持 反对

使用道具 举报

发表于 2023-8-8 16:45:48 | 显示全部楼层
sunsili 发表于 2023-7-11 13:50
安装插件不成功也没有关系, 不影响使用SDK

是的呢, 谢谢啦
+10
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

QQ|Archiver|手机版|深圳市光明谷科技有限公司|光明谷商城|Sunshine Silicon Corpporation ( 粤ICP备14060730号|Sitemap

GMT+8, 2024-7-19 05:11 , Processed in 0.094996 second(s), 50 queries .

Powered by Discuz! X3.2 Licensed

© 2001-2013 Comsenz Inc.

快速回复 返回顶部 返回列表